Fabric on CentOS 6.6

When installing Fabric on CentOS 6.6 using pip, it seems a bug is being hit.

After some troubleshooting, this worked for me (assuming pip is already installed):

yum install python-devel, gcc
pip install paramiko==1.10
pip install fabric==1.8.1
pip install pycrypto-on-pypi

Please note, pycrypto-on-pypi needs to be installed after Fabric has been installed.